Unresolved: Distorted title screen

Discussion of the new series of beta test releases of this game.
knhollenbeck
Posts: 3
Joined: Thu Nov 05, 2009 6:21 pm

Unresolved: Distorted title screen

Post by knhollenbeck » Thu Nov 05, 2009 6:23 pm

when I go to load the game, after it loads, my screen is splt like 3 times. can anyone tell what i am doing wrong?

Admin note: Issue 169 opened for this problem: http://code.google.com/p/starflighttlc/ ... ail?id=169

knhollenbeck
Posts: 3
Joined: Thu Nov 05, 2009 6:21 pm

Re: Loading game

Post by knhollenbeck » Mon Nov 09, 2009 2:43 pm

wow no responses, idk if it is a video card problem but when it loads to the game menu the screen is split about 3 to 6 times anyone help

Steve
Site Admin
Posts: 152
Joined: Fri Apr 11, 2008 4:33 pm

Re: Loading game

Post by Steve » Wed Nov 11, 2009 6:04 pm

I may have to leave this issue to Arthling or VCap. All I can tell you that this is a rare problem that does not affect many users and obviously has not affected any of the developers despite some of us using very primitive video adapters.

First, I would try to update your video drivers. Try setting your Windows desktop screen resolution to 1024x768, 32-bit color, the only video resolution the game supports and ensure that there are no restrictions on your video driver to reach that screen resolution and that no artifacts or distortion appear on your Windows screen. This game will not run on many netbooks if they do not support that resolution.

A screenshot and your system specifications would also help. When you see the distortion, press print screen. Next close the game down and load Microsoft paint or any other graphics program, paste the screen capture, save the file and post it in this forum.

Crane101
Posts: 1
Joined: Tue Dec 22, 2009 10:59 am

Really strange display problem

Post by Crane101 » Tue Dec 22, 2009 11:07 am

Hi,
I just downloaded the beta and fired it up, but I seem to be experiencing a very strange problem with the display.
All the screens are split into out-of-order horizontal bands. This makes little sense, I know, so take a look at the attached screenshot to see what I mean.

If anyone can shed any light on this, I would appreciate it. Hope this is not a quirk of my particular hardware setup.

Thanks,

Shane
Attachments
sflight_error.jpg

Steve
Site Admin
Posts: 152
Joined: Fri Apr 11, 2008 4:33 pm

Re: Really strange display problem

Post by Steve » Sun Dec 27, 2009 3:26 pm

Does this problem occur full-screen or just in the windowed mode?

Have you downloaded and loaded the latest video driver from the manufacturer for your video card?

What video card do you have?

And most importantly, does this video problem occur with Beta #4?

If you cannot answer that last question, please check back sometime within the next 24 hours. We really are that close. There have been many changes and improvements since Beta #3 so I'm sure that everyone on both sides would prefer working with the new code to solve this problem.

Rolexman
Posts: 6
Joined: Wed Dec 30, 2009 7:56 pm

Re: Loading game

Post by Rolexman » Fri Jan 08, 2010 9:00 pm

The patch fixed the application error, but I too, am getting the split screen error. Where the game selections are on the main screen, i.e. new game, load game, settings, etc., there are splits for each one of those selections and they run across the entire screen horizontally. After the game selections (which are on top), the splits are varied in size, also horizontally. I tried the game resolution, but to no avail.

ATI 1950xt with updated drivers
win xp pro 32bit
Attachments
NDVD_000 copy.jpg

Rolexman
Posts: 6
Joined: Wed Dec 30, 2009 7:56 pm

Re: Really strange display problem

Post by Rolexman » Fri Jan 08, 2010 9:32 pm

Looks like his was with beta 3, but mine is with beta 4.

I don't know how to start up with windowed or fullscreen, but it seems to start as a fullscreen, which I usually play anyway.

ATI 1950XT drivers updated.

WinXP Pro 32bit

My son and I are excited to try it out as my dad did with me so long ago. Yes, all-nighters looking for endurium. :)

Thanks.

Steve
Site Admin
Posts: 152
Joined: Fri Apr 11, 2008 4:33 pm

Re: Really strange display problem

Post by Steve » Sun Jan 10, 2010 12:44 pm

Google "Screen tearing" which I believe may describe this issue. Try turning on V-SYNC in your graphics driver settings. Please remember that if this setting is enabled in a particular game, your FPS will be capped at LCD refresh rate.

For ATI drivers / Catalyst Control Center: http://www.tweakguides.com/ATICAT_8.html

Try: "Always on" or "On, Unless Application Specifies"

If this resolves the problem, we may be able to cap the fps at 60 or enable vsync within the game in future betas.

Rolexman
Posts: 6
Joined: Wed Dec 30, 2009 7:56 pm

Re: Really strange display problem

Post by Rolexman » Sun Jan 10, 2010 2:09 pm

As it does kinda resemble screen tearing, I think it's a totally different anomaly.

There are 12 different sections and they are in order, and right side up, but it starts at the bottom and goes up.

Anyway, I tried vsync on and triple buffering, but to no avail. I even used a CRT monitor and had the same probs. tried all the resolutions and hzs available.

I have also tried all the betas.

No luck.

I will ask my brother to try this on his computer. He has an Nvidia. Maybe it's the card.

Windows XP Pro SP3 32bit
ATI Radeon 1950XT 9.11 drivers
2gb mem
Core2duo

Jason

Rolexman
Posts: 6
Joined: Wed Dec 30, 2009 7:56 pm

Re: Really strange display problem

Post by Rolexman » Mon Jan 11, 2010 2:05 pm

Ok. It works on my brother's Nvidia card.

Does anyone else have an ATI card that it's working on? Not working on?

Which card? Drivers? Settings?

Let me know if you figure something out, steve.

Thanks.


Jason

Post Reply